mirror of
http://git.openwrt.org/packages.git
synced 2025-01-08 11:57:34 +08:00
at: moved to github
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@47502 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7a333896dd
commit
87650ede3f
@ -1,56 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2008-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=at
|
||||
PKG_VERSION:=3.1.13
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/a/at
|
||||
PKG_MD5SUM:=1da61af6c29e323abaaf13ee1a8dad79
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/at
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libelf1
|
||||
TITLE:=Delayed job execution and batch processing
|
||||
URL:=http://packages.debian.org/stable/at
|
||||
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
||||
endef
|
||||
|
||||
define Package/at/description
|
||||
At and batch read shell commands from standard input storing them as a job to
|
||||
be scheduled for execution in the future.
|
||||
endef
|
||||
|
||||
export SENDMAIL=/bin/true
|
||||
EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) \
|
||||
$(TARGET_LDFLAGS)
|
||||
|
||||
CONFIGURE_ARGS+=--prefix=/usr \
|
||||
--with-daemon_username=nobody \
|
||||
--with-daemon_groupname=nogroup \
|
||||
--with-jobdir=/var/spool/cron/atjobs \
|
||||
--with-atspool=/var/spool/cron/atspool
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_header_security_pam_appl_h=no
|
||||
|
||||
define Package/at/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/
|
||||
$(INSTALL_BIN) ./files/atd.init $(1)/etc/init.d/atd
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/at $(1)/usr/bin
|
||||
ln -sf at $(1)/usr/bin/atq
|
||||
ln -sf at $(1)/usr/bin/atrm
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/atd $(1)/usr/sbin
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,at))
|
@ -1,23 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2011 OpenWrt.org
|
||||
|
||||
START=50
|
||||
|
||||
SERVICE_USE_PID=1
|
||||
|
||||
start() {
|
||||
[ -d /var/spool/cron/atjobs ] || {
|
||||
mkdir -m 0755 -p /var/spool/cron/atjobs
|
||||
touch /var/spool/cron/atjobs/.SEQ
|
||||
chown -R nobody:nogroup /var/spool/cron/atjobs
|
||||
}
|
||||
[ -d /var/spool/cron/atspool ] || {
|
||||
mkdir -m 0755 -p /var/spool/cron/atspool
|
||||
chown -R nobody:nogroup /var/spool/cron/atspool
|
||||
}
|
||||
service_start /usr/sbin/atd
|
||||
}
|
||||
|
||||
stop() {
|
||||
service_stop /usr/sbin/atd
|
||||
}
|
@ -1,30 +0,0 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3458,27 +3458,6 @@ $as_echo "yes" >&6; }
|
||||
$as_echo "no" >&6; }
|
||||
;;
|
||||
esac
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking Trying to compile a trivial ANSI C program" >&5
|
||||
-$as_echo_n "checking Trying to compile a trivial ANSI C program... " >&6; }
|
||||
-if test "$cross_compiling" = yes; then :
|
||||
- as_fn_error $? "Could not compile and run even a trivial ANSI C program - check CC." "$LINENO" 5
|
||||
-else
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
- main(int ac, char **av) { return 0; }
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_run "$LINENO"; then :
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- as_fn_error $? "Could not compile and run even a trivial ANSI C program - check CC." "$LINENO" 5
|
||||
-fi
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
|
||||
- conftest.$ac_objext conftest.beam conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking __attribute__((noreturn))" >&5
|
||||
$as_echo_n "checking __attribute__((noreturn))... " >&6; }
|
@ -1,14 +0,0 @@
|
||||
--- a/getloadavg.c
|
||||
+++ b/getloadavg.c
|
||||
@@ -69,8 +69,9 @@ Boston, MA 02110-1301 USA */
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
-#include "lisp.h"
|
||||
-#include "sysfile.h" /* for encapsulated open, close, read, write */
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
+#include <fcntl.h>
|
||||
|
||||
#ifndef HAVE_GETLOADAVG
|
||||
|
Loading…
Reference in New Issue
Block a user