massive python changes:

* move all python packages to lang section
 * add a python-package.mk rules file sourced by all python packages for PyPackage/* defs
 * introduce a new way of specifying files to be packaged (experimental)
 * add missing svn:properties


git-svn-id: svn://svn.openwrt.org/openwrt/packages@8639 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-09-06 02:52:35 +00:00
parent dd17cb27a0
commit b94f02fe5f
20 changed files with 445 additions and 456 deletions

89
lang/egenix-mx/Makefile Normal file
View File

@ -0,0 +1,89 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=egenix-mx
PKG_VERSION:=2.0.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-base-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.egenix.com/files/python/
PKG_MD5SUM:=66841151728a06f92d0b8dd2ed317a29
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-base-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define PyPackage/egenix-mx
TITLE:=Egenix mxBase
URL:=http://www.egenix.com/products/python/mxBase/
endef
define PyPackage/egenix-mx/description
This package contains a set of base packages from Egenix required by other
python packages.
endef
define Build/Compile
$(call Build/Compile/PyMod,., \
build --build-lib="foo", \
BASECFLAGS="$(TARGET_CFLAGS)" \
OPT="" \
)
endef
define Build/InstallDev
mkdir -p $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/BeeBase/mxBeeBase
$(CP) \
$(PKG_BUILD_DIR)/mx/BeeBase/mxBeeBase/mxh.h \
$(PKG_BUILD_DIR)/mx/BeeBase/mxBeeBase/btr.h \
$(PKG_BUILD_DIR)/mx/BeeBase/mxBeeBase/mxBeeBase.h \
$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/BeeBase/mxBeeBase/
mkdir -p $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime
$(CP) \
$(PKG_BUILD_DIR)/mx/DateTime/mxDateTime/mxh.h \
$(PKG_BUILD_DIR)/mx/DateTime/mxDateTime/mxDateTime.h \
$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime/
mkdir -p $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/Proxy/mxProxy
$(CP) \
$(PKG_BUILD_DIR)/mx/Proxy/mxProxy/mxh.h \
$(PKG_BUILD_DIR)/mx/Proxy/mxProxy/mxProxy.h \
$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/Proxy/mxProxy/
mkdir -p $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/Queue/mxQueue
$(CP) \
$(PKG_BUILD_DIR)/mx/Queue/mxQueue/mxh.h \
$(PKG_BUILD_DIR)/mx/Queue/mxQueue/mxQueue.h \
$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/Queue/mxQueue/
mkdir -p $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/TextTools/mxTextTools
$(CP) \
$(PKG_BUILD_DIR)/mx/TextTools/mxTextTools/mxh.h \
$(PKG_BUILD_DIR)/mx/TextTools/mxTextTools/mxbmse.h \
$(PKG_BUILD_DIR)/mx/TextTools/mxTextTools/mxte.h \
$(PKG_BUILD_DIR)/mx/TextTools/mxTextTools/mxTextTools.h \
$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/TextTools/mxTextTools/
mkdir -p $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/Tools/mxTools
$(CP) \
$(PKG_BUILD_DIR)/mx/Tools/mxTools/mxh.h \
$(PKG_BUILD_DIR)/mx/Tools/mxTools/mxTools.h \
$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/Tools/mxTools/
endef
define Build/UninstallDev
rm -rf $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx
endef
define PyPackage/egenix-mx/install
$(CP) $(PKG_BUILD_DIR)/foo/mx $(1)$(PYTHON_PKG_DIR)/
ln -sf $(1)$(PYTHON_PKG_DIR)/mx/BeeBase/ExitFunctions.py \
$(1)$(PYTHON_PKG_DIR)/mx/Misc/
rm -rf $(1)$(PYTHON_PKG_DIR)/mx/*/Examples
endef
$(eval $(call PyPackage,egenix-mx))

View File

@ -1,3 +1,11 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=kid
@ -7,29 +15,29 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.kid-templating.org/dist/0.9.6/dist
PKG_MD5SUM:=31e7156698a6f214b4067afb9e13728f
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define Package/kid
SECTION:=lang
CATEGORY:=Languages
TITLE:=Kid
DEPENDS:=+python
DESCRIPTION:=\
Kid is a simple template language for XML based vocabularies written in Python.
define PyPackage/kid
TITLE:=XML-based Templating
URL=http://www.kid-templating.org/
endef
define PyPackage/kid/description
Kid is a simple template language for XML based vocabularies written in
Python.
endef
define PyPackage/kid/filespec
+|$(PYTHON_PKG_DIR)/kid
-|$(PYTHON_PKG_DIR)/kid/test
endef
define Build/Compile
$(call Build/Compile/PyMod,,install)
$(call Build/Compile/PyMod,., \
install --prefix="$(PKG_INSTALL_DIR)/usr", \
)
endef
define Package/kid/install
$(CP) -R $(PKG_INSTALL_DIR)/* $(1)
endef
$(eval $(call BuildPackage,kid))
$(eval $(call PyPackage,kid))

49
lang/psycopg/Makefile Normal file
View File

@ -0,0 +1,49 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=psycopg
PKG_VERSION:=1.1.21
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.initd.org/pub/software/psycopg/
PKG_MD5SUM:=a31f79f68d6d32898d6f24e11369a106
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define PyPackage/psycopg
TITLE:=PostgreSQL database adapter
URL=http://www.initd.org/
DEPENDS+= +libpq +egenix-mx
endef
define PyPackage/psycopg/description
This package contains is a PostgreSQL database adapter for the Python
programming language.
endef
CONFIGURE_ARGS += \
--with-python="$(PYTHON)" \
--with-postgres-libraries="$(STAGING_DIR)/usr/lib" \
--with-postgres-includes="$(STAGING_DIR)/usr/include" \
--with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
OPT="$(TARGET_CFLAGS)"
endef
define PyPackage/psycopg/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(INSTALL_BIN) $(PKG_BUILD_DIR)/psycopgmodule.so $(1)$(PYTHON_PKG_DIR)/
endef
$(eval $(call PyPackage,psycopg))

39
lang/pyevent/Makefile Normal file
View File

@ -0,0 +1,39 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=pyevent
PKG_VERSION:=0.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pyevent.googlecode.com/files/
PKG_MD5SUM:=584912c92d08bf005283fb29a47a6e4d
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define PyPackage/pyevent
TITLE:=Python interface to libevent
URL=http://code.google.com/p/pyevent/
DEPENDS+= +libevent
endef
define PyPackage/pyevent/filespec
+|$(PYTHON_PKG_DIR)/event.so
endef
define Build/Compile
$(call Build/Compile/PyMod,., \
install --prefix="$(PKG_INSTALL_DIR)/usr", \
LIBEVENT_HOME="$(STAGING_DIR)/usr/lib" \
)
endef
$(eval $(call PyPackage,pyevent))

39
lang/pypcap/Makefile Normal file
View File

@ -0,0 +1,39 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=pypcap
PKG_VERSION:=1.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pypcap.googlecode.com/files
PKG_MD5SUM:=034c3cbbfa81aa19e8f685b767c65764
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define PyPackage/pypcap
TITLE:=Python interface to lipcap
URL:=http://code.google.com/p/pypcap/
DEPENDS+= +libpcap
endef
define PyPackage/pypcap/filespec
+|$(PYTHON_PKG_DIR)/pcap.so
endef
define Build/Compile
$(call Build/Compile/PyMod,., \
install --prefix="$(PKG_INSTALL_DIR)/usr", \
PCAP_HOME="$(STAGING_DIR)/usr" \
)
endef
$(eval $(call PyPackage,pypcap))

44
lang/pysqlite/Makefile Normal file
View File

@ -0,0 +1,44 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=pysqlite
PKG_VERSION:=2.3.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://initd.org/pub/software/pysqlite/releases/2.3/2.3.5/
PKG_MD5SUM:=b4a185e936848370fcc1a5b17755b641
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define PyPackage/pysqlite
TITLE:=SQLite database adapter
URL=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
DEPENDS+= +libsqlite3
endef
define PyPackage/pysqlite/description
This package contains an SQLite database adapter for the Python
programming language.
endef
define PyPackage/pysqlite/filespec
+|$(PYTHON_PKG_DIR)/pysqlite2
-|$(PYTHON_PKG_DIR)/pysqlite2/test
endef
define Build/Compile
$(call Build/Compile/PyMod,., \
install --prefix="$(PKG_INSTALL_DIR)/usr", \
)
endef
$(eval $(call PyPackage,pysqlite))

View File

@ -28,7 +28,7 @@ PY_DISABLED_MODULES=\
define Package/python
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+uclibcxx +libpthread +libreadline +libncurses +libopenssl +libexpat
DEPENDS:=+libexpat +libopenssl +libpthread +libreadline +uclibcxx
TITLE:=Python 2.5 programming language
URL:=http://www.python.org/
endef
@ -66,15 +66,15 @@ define Build/Configure
endef
MAKE_OPTS:=\
$(TARGET_CONFIGURE_OPTS) \
PYTHON_MODULES_INCLUDE=$(STAGING_DIR)/include \
PYTHON_MODULES_LIB=$(STAGING_DIR)/lib \
PYTHON_DISABLE_MODULES="$(PY_DISABLED_MODULES)" \
CFLAGS="$(TARGET_CFLAGS) -fno-inline" \
LDFLAGS="$(TARGET_LDFLAGS) -lncurses" \
LD="$(TARGET_CC)" \
HOSTPYTHON=./hostpython \
HOSTPGEN=./Parser/hostpgen
$(TARGET_CONFIGURE_OPTS) \
PYTHON_MODULES_INCLUDE=$(STAGING_DIR)/include \
PYTHON_MODULES_LIB=$(STAGING_DIR)/lib \
PYTHON_DISABLE_MODULES="$(PY_DISABLED_MODULES)" \
CFLAGS="$(TARGET_CFLAGS) -fno-inline" \
LDFLAGS="$(TARGET_LDFLAGS)" \
LD="$(TARGET_CC)" \
HOSTPYTHON=./hostpython \
HOSTPGEN=./Parser/hostpgen
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
@ -92,12 +92,13 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/python2.5 $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python2.5 $(STAGING_DIR)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/libpython2.5.a $(STAGING_DIR)/usr/lib/python2.5
$(CP) $(PKG_BUILD_DIR)/libpython2.5.a $(STAGING_DIR)/usr/lib/python2.5/
endef
define Build/UninstallDev
rm -rf \
$(STAGING_DIR)/usr/{include,lib}/python2.5
rm -rf $(STAGING_DIR)/usr/bin/hostpython \
$(STAGING_DIR)/usr/include/python2.5 \
$(STAGING_DIR)/usr/lib/python2.5
endef
define Package/python/install
@ -108,8 +109,7 @@ define Package/python/install
$(CP) $(PKG_INSTALL_DIR)/usr/include/python2.5/Python.h $(1)/usr/include/python2.5/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python2.5 $(1)/usr/lib/
rm -rf \
$(1)/usr/lib/python2.5/bsddb/test \
rm -rf $(1)/usr/lib/python2.5/bsddb/test \
$(1)/usr/lib/python2.5/distutils/tests \
$(1)/usr/lib/python2.5/email/test \
$(1)/usr/lib/python2.5/idlelib \

View File

@ -0,0 +1,82 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
ifeq ($(DUMP),)
PYTHON:=$(STAGING_DIR)/usr/bin/hostpython
PYTHON_VERSION=2.5
PYTHON_INC_DIR:=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION)
PYTHON_LIB_DIR:=$(STAGING_DIR)/usr/lib/python$(PYTHON_VERSION)
PYTHON_PKG_DIR:=/usr/lib/python$(PYTHON_VERSION)/site-packages
endif
define PyPackage
NAME:=$(1)
$(eval $(call PyPackage/$(1)))
define Package/$(1)
TITLE:=$(TITLE)
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+python
$(call PyPackage/$(1))
endef
ifdef PyPackage/$(1)/description
define Package/$(1)/description
$(call PyPackage/$(1)/description)
endef
endif
$(call shexport,PyPackage/$(1)/filespec)
define Package/$(1)/install
@getvar $$(call shvar,PyPackage/$(1)/filespec) | ( \
IFS='|'; \
while read fop fspec fperm; do \
if [ "$$$$$$$$fop" = "+" ]; then \
dpath=`dirname "$$$$$$$$fspec"`; \
if [ -n "$$$$$$$$fperm" ]; then \
dperm="-m$$$$$$$$fperm"; \
else \
dperm=`stat -c "%a" $(PKG_INSTALL_DIR)$$$$$$$$dpath`; \
fi; \
mkdir -p $$$$$$$$$dperm $$(1)$$$$$$$$dpath; \
echo "copying: '$$$$$$$$fspec'"; \
cp -fpR $(PKG_INSTALL_DIR)$$$$$$$$fspec $$(1)$$$$$$$$dpath/; \
if [ -n "$$$$$$$$fperm" ]; then \
chmod -R $$$$$$$$fperm $$(1)$$$$$$$$fspec; \
fi; \
elif [ "$$$$$$$$fop" = "-" ]; then \
echo "removing: '$$$$$$$$fspec'"; \
rm -fR $$(1)$$$$$$$$fspec; \
elif [ "$$$$$$$$fop" = "=" ]; then \
echo "setting permissions: '$$$$$$$$fperm' on '$$$$$$$$fspec'"; \
chmod -R $$$$$$$$fperm $$(1)$$$$$$$$fspec; \
fi; \
done; \
)
$(call PyPackage/$(1)/install,$$(1))
endef
$$(eval $$(call BuildPackage,$(1)))
endef
define Build/Compile/PyMod
( cd $(PKG_BUILD_DIR)/$(1); \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="$(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
$(3) \
$(PYTHON) ./setup.py $(2) \
);
endef

63
lang/yapsnmp/Makefile Normal file
View File

@ -0,0 +1,63 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=yapsnmp
PKG_VERSION:=0.7.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=8a3e9a5b814388d7907c639105cb2365
include $(INCLUDE_DIR)/package.mk
include ../python/python-package.mk
define PyPackage/yapsnmp
TITLE:=Python interface to Net-SNMP
URL:=http://yapsnmp.sourceforge.net/
DEPENDS+= +libnetsnmp
endef
define PyPackage/yapsnmp/description
This package contains a Python SNMP module based on the net-snmp (formerly
known as ucd-snmp) library. It's composed of a low level interface to the
library, created using SWIG, and a higher level python module removing all
the complexity out of dealing with SNMP.
endef
define PyPackage/yapsnmp/filespec
+|$(PYTHON_PKG_DIR)/netsnmp.py
+|$(PYTHON_PKG_DIR)/netsnmpc.so
+|$(PYTHON_PKG_DIR)/yapsnmp.py
endef
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--enable-site-packages-prefix="$(PYTHON_PKG_DIR)" \
CONFIGURE_VARS += \
ac_cv_file__usr_include_net_snmp_library="yes" \
define Build/Configure
$(call Build/Configure/Default)
$(call libtool_disable_rpath)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
INCLUDES="-I$(PYTHON_INC_DIR)" \
SNMPINCDIR="$(STAGING_DIR)/usr/include/net-snmp/library" \
all
$(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
endef
$(eval $(call PyPackage,yapsnmp))

View File

@ -336,90 +336,3 @@
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
/* confdefs.h. */
--- yapsnmp-0.7.8/configure.old 2007-07-19 16:31:52.277415884 -0500
+++ yapsnmp-0.7.8/configure 2007-07-19 16:36:41.477896480 -0500
@@ -9262,35 +9262,6 @@
done
-
-for TEMP in $oldincludedir $ac_default_prefix/include $prefix/include
-do
- SNMPINCDIR=$TEMP/$NETINCL
- as_ac_File=`echo "ac_cv_file_$SNMPINCDIR" | $as_tr_sh`
-echo "$as_me:$LINENO: checking for $SNMPINCDIR" >&5
-echo $ECHO_N "checking for $SNMPINCDIR... $ECHO_C" >&6
-if eval "test \"\${$as_ac_File+set}\" = set"; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
-if test -r "$SNMPINCDIR"; then
- eval "$as_ac_File=yes"
-else
- eval "$as_ac_File=no"
-fi
-fi
-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
-echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
-if test `eval echo '${'$as_ac_File'}'` = yes; then
- break
-fi
-
-done
-
-
for PYTHONINCPATH in python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
do
as_ac_Header=`echo "ac_cv_header_$PYTHONINCPATH/Python.h" | $as_tr_sh`
--- yapsnmp-0.7.8/configure.old 2007-07-19 16:37:52.729956905 -0500
+++ yapsnmp-0.7.8/configure 2007-07-19 16:39:47.880518956 -0500
@@ -9406,35 +9406,6 @@
if test "${enable_site_packages_prefix+set}" = set; then
enableval="$enable_site_packages_prefix"
SITEPACKAGE=\$\(exec_prefix\)/lib/$PYTHONINCPATH/site-packages
-else
-
-for TEMP in /usr/lib $ac_default_prefix/lib $prefix/lib
-do
- SITEPACKAGE=$TEMP/$PYTHONINCPATH/site-packages
- as_ac_File=`echo "ac_cv_file_$SITEPACKAGE" | $as_tr_sh`
-echo "$as_me:$LINENO: checking for $SITEPACKAGE" >&5
-echo $ECHO_N "checking for $SITEPACKAGE... $ECHO_C" >&6
-if eval "test \"\${$as_ac_File+set}\" = set"; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
-if test -r "$SITEPACKAGE"; then
- eval "$as_ac_File=yes"
-else
- eval "$as_ac_File=no"
-fi
-fi
-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
-echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
-if test `eval echo '${'$as_ac_File'}'` = yes; then
- break
-fi
-
-done
-
fi;
--- yapsnmp-0.7.8/src/Makefile.in.old 2007-07-19 21:38:20.589306061 -0500
+++ yapsnmp-0.7.8/src/Makefile.in 2007-07-19 21:38:37.290257791 -0500
@@ -180,7 +180,7 @@
rm -f "$${dir}/so_locations"; \
done
netsnmpc.la: $(netsnmpc_la_OBJECTS) $(netsnmpc_la_DEPENDENCIES)
- $(LINK) -rpath $(libdir) $(netsnmpc_la_LDFLAGS) $(netsnmpc_la_OBJECTS) $(netsnmpc_la_LIBADD) $(LIBS)
+ $(LINK) -rpath /usr/lib $(netsnmpc_la_LDFLAGS) $(netsnmpc_la_OBJECTS) $(netsnmpc_la_LIBADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT) core *.core

View File

@ -1,114 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=egenix-mx
PKG_VERSION:=2.0.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-base-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.egenix.com/files/python/
PKG_MD5SUM:=66841151728a06f92d0b8dd2ed317a29
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-base-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/egenix-mx
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+python
TITLE:=Egenix-mx
MAINTAINER:=jjones@pavlovmedia.com
DESCRIPTION:=\
required library for psycopg (a PostgreSQL database adapter for the Python programming language).
URL=http://www.initd.org/
endef
define Build/Compile
cd $(PKG_BUILD_DIR); \
BASECFLAGS='$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include' \
CFLAGS='$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include' \
LDFLAGS='$(TARGET_LDFLAGS)' \
$(STAGING_DIR)/usr/bin/hostpython ./setup.py build \
--build-lib=foo
endef
MX_SOURCE=$(PKG_BUILD_DIR)/mx
MX_INSTALL_DIR=/usr/lib/python2.5/site-packages/mx
define Package/egenix-mx/install
# distutils insists on compiling, so we need to do an install by hand
$(INSTALL_DIR) $(1)/usr/lib/python2.5/site-packages
$(CP) -R $(PKG_BUILD_DIR)/foo/mx $(1)/usr/lib/python2.5/site-packages
$(CP) $(1)$(MX_INSTALL_DIR)/BeeBase/ExitFunctions.py \
$(1)$(MX_INSTALL_DIR)/Misc/ExitFunctions.py
$(CP) \
$(MX_SOURCE)/BeeBase/mxBeeBase/btr.h \
$(MX_SOURCE)/BeeBase/mxBeeBase/mxBeeBase.h \
$(MX_SOURCE)/BeeBase/mxBeeBase/mxh.h \
$(1)$(MX_INSTALL_DIR)/BeeBase/mxBeeBase/
$(CP) \
$(MX_SOURCE)/DateTime/mxDateTime/mxDateTime.h \
$(MX_SOURCE)/DateTime/mxDateTime/mxh.h \
$(1)$(MX_INSTALL_DIR)/DateTime/mxDateTime/
$(CP) \
$(MX_SOURCE)/Proxy/mxProxy/mxh.h \
$(MX_SOURCE)/Proxy/mxProxy/mxProxy.h \
$(1)$(MX_INSTALL_DIR)/Proxy/mxProxy/
$(CP) \
$(MX_SOURCE)/Queue/mxQueue/mxh.h \
$(MX_SOURCE)/Queue/mxQueue/mxQueue.h \
$(1)$(MX_INSTALL_DIR)/Queue/mxQueue/
$(CP) \
$(MX_SOURCE)/TextTools/mxTextTools/mxbmse.h \
$(MX_SOURCE)/TextTools/mxTextTools/mxh.h \
$(MX_SOURCE)/TextTools/mxTextTools/mxte.h \
$(MX_SOURCE)/TextTools/mxTextTools/mxTextTools.h \
$(1)$(MX_INSTALL_DIR)/TextTools/mxTextTools/
$(CP) \
$(MX_SOURCE)/Tools/mxTools/mxh.h \
$(MX_SOURCE)/Tools/mxTools/mxTools.h \
$(1)$(MX_INSTALL_DIR)/Tools/mxTools/
chmod -R a+r $(1)
endef
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)$(MX_INSTALL_DIR)/BeeBase/mxBeeBase
$(INSTALL_DIR) $(STAGING_DIR)$(MX_INSTALL_DIR)/DateTime/mxDateTime
$(INSTALL_DIR) $(STAGING_DIR)$(MX_INSTALL_DIR)/Proxy/mxProxy
$(INSTALL_DIR) $(STAGING_DIR)$(MX_INSTALL_DIR)/Queue/mxQueue
$(INSTALL_DIR) $(STAGING_DIR)$(MX_INSTALL_DIR)/TextTools/mxTextTools
$(INSTALL_DIR) $(STAGING_DIR)$(MX_INSTALL_DIR)/Tools/mxTools
$(CP) \
$(MX_SOURCE)/BeeBase/mxBeeBase/btr.h \
$(MX_SOURCE)/BeeBase/mxBeeBase/mxBeeBase.h \
$(MX_SOURCE)/BeeBase/mxBeeBase/mxh.h \
$(STAGING_DIR)$(MX_INSTALL_DIR)/BeeBase/mxBeeBase/
$(CP) \
$(MX_SOURCE)/DateTime/mxDateTime/mxDateTime.h \
$(MX_SOURCE)/DateTime/mxDateTime/mxh.h \
$(STAGING_DIR)$(MX_INSTALL_DIR)/DateTime/mxDateTime/
$(CP) \
$(MX_SOURCE)/Proxy/mxProxy/mxh.h \
$(MX_SOURCE)/Proxy/mxProxy/mxProxy.h \
$(STAGING_DIR)$(MX_INSTALL_DIR)/Proxy/mxProxy/
$(CP) \
$(MX_SOURCE)/Queue/mxQueue/mxh.h \
$(MX_SOURCE)/Queue/mxQueue/mxQueue.h \
$(STAGING_DIR)$(MX_INSTALL_DIR)/Queue/mxQueue/
$(CP) \
$(MX_SOURCE)/TextTools/mxTextTools/mxbmse.h \
$(MX_SOURCE)/TextTools/mxTextTools/mxh.h \
$(MX_SOURCE)/TextTools/mxTextTools/mxte.h \
$(MX_SOURCE)/TextTools/mxTextTools/mxTextTools.h \
$(STAGING_DIR)$(MX_INSTALL_DIR)/TextTools/mxTextTools/
$(CP) \
$(MX_SOURCE)/Tools/mxTools/mxh.h \
$(MX_SOURCE)/Tools/mxTools/mxTools.h \
$(STAGING_DIR)$(MX_INSTALL_DIR)/Tools/mxTools/
endef
$(eval $(call BuildPackage,egenix-mx))

View File

@ -1,45 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=psycopg
PKG_VERSION:=1.1.21
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.initd.org/pub/software/psycopg/
PKG_MD5SUM:=a31f79f68d6d32898d6f24e11369a106
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/psycopg
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libpq +python +egenix-mx
TITLE:=Psycopg
MAINTAINER:=jjones@pavlovmedia.com
DESCRIPTION:=\
psycopg is a PostgreSQL database adapter for the Python programming language.
URL=http://www.initd.org/
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
endef
define Build/Configure
$(call Build/Configure/Default, \
--with-python=$(STAGING_DIR)/usr/bin/hostpython \
--with-postgres-libraries=$(STAGING_DIR)/usr/lib \
--with-postgres-includes=$(STAGING_DIR)/usr/include \
--with-mxdatetime-includes=$(STAGING_DIR)/usr/lib/python2.5/site-packages/mx/DateTime/mxDateTime )
endef
define Package/psycopg/install
$(INSTALL_DIR) $(1)/usr/lib/python2.5/site-packages
$(INSTALL_BIN) $(PKG_BUILD_DIR)/psycopgmodule.so $(1)/usr/lib/python2.5/site-packages
endef
$(eval $(call BuildPackage,psycopg))

View File

@ -1,40 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pyevent
PKG_VERSION:=0.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pyevent.googlecode.com/files/
PKG_MD5SUM:=584912c92d08bf005283fb29a47a6e4d
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/pyevent
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libevent +python
TITLE:=Pyevent
MAINTAINER:=jjones@pavlovmedia.com
DESCRIPTION:=\
Python extension module for libevent
URL=http://code.google.com/p/pyevent/
endef
define Build/Compile
$(call Build/Compile/PyMod,\
LIBEVENT_HOME='$(STAGING_DIR)/usr/lib' \
,\
install \
)
endef
define Package/pyevent/install
$(CP) -R $(PKG_INSTALL_DIR)/* $(1)
endef
$(eval $(call BuildPackage,pyevent))

View File

@ -1,35 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pysqlite
PKG_VERSION:=2.3.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://initd.org/pub/software/pysqlite/releases/2.3/2.3.5/
PKG_MD5SUM:=b4a185e936848370fcc1a5b17755b641
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/pysqlite
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libsqlite3 +python
TITLE:=Pysqlite
DESCRIPTION:=\
pysqlite is a sqlite database adapter for the Python programming language.
URL=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
endef
define Build/Compile
$(call Build/Compile/PyMod,,install)
endef
define Package/pysqlite/install
$(CP) -R $(PKG_INSTALL_DIR)/* $(1)
endef
$(eval $(call BuildPackage,pysqlite))

View File

@ -1,62 +0,0 @@
#
#
include $(TOPDIR)/rules.mk
PKG_NAME:=yapsnmp
PKG_VERSION:=0.7.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=8a3e9a5b814388d7907c639105cb2365
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/yapsnmp
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Python SNMP module
DEPENDS:=+libnetsnmp +python
DESCRIPTION:=\
yapsnmp is a Python SNMP module based on the net-snmp (formerly known \\\
as ucd-snmp) library. It's composed of a low level interface to the \\\
library, created using SWIG, and a higher level python module \\\
removing all the complexity out of dealing with SNMP.
URL:=http://yapsnmp.sourceforge.net/
endef
define Build/Configure
$(call Build/Configure/Default, \
--includedir="$(STAGING_DIR)/usr/include" \
--oldincludedir="$(STAGING_DIR)/usr/include" \
--enable-shared \
--enable-static \
)
endef
define Build/Compile
$(SED) 's#^oldincludedir.*#oldincludedir = $(STAGING_DIR)/usr/include#' \
$(PKG_BUILD_DIR)/src/Makefile
$(SED) 's#^sys_lib_search_path_spec.*#sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib"#' \
$(PKG_BUILD_DIR)/libtool
$(MAKE) -C $(PKG_BUILD_DIR) \
SNMPINCDIR="$(STAGING_DIR)/usr/include/net-snmp/library" \
includedir="$(STAGING_DIR)/usr/include" \
DESTDIR=$(PKG_INSTALL_DIR) \
all install
endef
ifeq ($(DUMP),)
pylibdir:=$(shell $(STAGING_DIR)/usr/bin/hostpython $(SCRIPT_DIR)/pylibdir.py)
endif
define Package/yapsnmp/install
$(INSTALL_DIR) $(1)$(pylibdir)
$(CP) -a $(PKG_INSTALL_DIR)/* $(1)$(pylibdir)
endef
$(eval $(call BuildPackage,yapsnmp))

View File

@ -1,41 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pypcap
PKG_VERSION:=1.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pypcap.googlecode.com/files
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/pypcap
DEPENDS:=+python +libpcap
SECTION:=net
CATEGORY:=Network
TITLE:=pypcap
DESCRIPTION:=\
pypcap
URL:=http://www
endef
define Build/Compile
$(call Build/Compile/PyMod,\
PCAP_HOME=$(STAGING_DIR)/usr \
,\
install \
)
endef
define Package/pypcap/install
cd $(PKG_BUILD_DIR); \
$(STAGING_DIR)/usr/bin/hostpython ./setup.py install \
--no-compile --prefix $(PKG_INSTALL_DIR)/usr
cp -a $(PKG_INSTALL_DIR)/* $(1)/
endef
$(eval $(call BuildPackage,pypcap))