mirror of
http://git.openwrt.org/packages.git
synced 2025-01-09 04:19:54 +08:00
packages/python-imaging-library: fix cross compile
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29141 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cd42decb9f
commit
bf71bed5c7
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-imaging-library
|
||||
PKG_VERSION:=1.1.7
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=Imaging-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://effbot.org/downloads
|
||||
|
33
lang/python-imaging-library/patches/101-cross_compile.patch
Normal file
33
lang/python-imaging-library/patches/101-cross_compile.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- a/setup.py 2011-11-15 01:06:00.000000000 +0100
|
||||
+++ b/setup.py 2011-11-15 01:07:32.000000000 +0100
|
||||
@@ -147,7 +147,6 @@
|
||||
add_directory(library_dirs, "/opt/local/lib")
|
||||
add_directory(include_dirs, "/opt/local/include")
|
||||
|
||||
- add_directory(library_dirs, "/usr/local/lib")
|
||||
# FIXME: check /opt/stuff directories here?
|
||||
|
||||
prefix = sysconfig.get_config_var("prefix")
|
||||
@@ -199,22 +198,6 @@
|
||||
add_directory(include_dirs, include_root)
|
||||
|
||||
#
|
||||
- # add standard directories
|
||||
-
|
||||
- # look for tcl specific subdirectory (e.g debian)
|
||||
- if _tkinter:
|
||||
- tcl_dir = "/usr/include/tcl" + TCL_VERSION
|
||||
- if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
|
||||
- add_directory(include_dirs, tcl_dir)
|
||||
-
|
||||
- # standard locations
|
||||
- add_directory(library_dirs, "/usr/local/lib")
|
||||
- add_directory(include_dirs, "/usr/local/include")
|
||||
-
|
||||
- add_directory(library_dirs, "/usr/lib")
|
||||
- add_directory(include_dirs, "/usr/include")
|
||||
-
|
||||
- #
|
||||
# insert new dirs *before* default libs, to avoid conflicts
|
||||
# between Python PYD stub libs and real libraries
|
||||
|
Loading…
Reference in New Issue
Block a user