mirror of
http://git.openwrt.org/packages.git
synced 2025-01-08 11:57:34 +08:00
bc: moved to github
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@46321 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9797071bc0
commit
c0b17fb241
@ -1,61 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bc
|
||||
PKG_VERSION:=1.06.95
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.debian.org/debian/pool/main/b/bc
|
||||
PKG_MD5SUM:=24d0831812d8262b6cac8316b0bac483
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/bc/Default
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
URL:=http://packages.debian.org/bc
|
||||
endef
|
||||
|
||||
define Package/bc
|
||||
$(call Package/bc/Default)
|
||||
TITLE:=Arbitrary precision calculator language
|
||||
DEPENDS:=+libreadline +libncurses
|
||||
endef
|
||||
|
||||
define Package/bc/description
|
||||
bc is a language that supports arbitrary precision numbers with
|
||||
interactive execution of statements.
|
||||
endef
|
||||
|
||||
define Package/dc
|
||||
$(call Package/bc/Default)
|
||||
TITLE:=Arbitrary precision reverse-polish calculator
|
||||
DEPENDS:=bc
|
||||
endef
|
||||
|
||||
define Package/dc/description
|
||||
dc is a reverse-polish desk calculator which supports unlimited
|
||||
precision arithmetic.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += --with-readline
|
||||
|
||||
define Package/bc/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bc/bc $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/dc/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dc/dc $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,bc))
|
||||
$(eval $(call BuildPackage,dc))
|
@ -1,21 +0,0 @@
|
||||
--- bc-1.06.95/Makefile.in 2010-07-03 10:48:13.422725147 +0000
|
||||
+++ bc-1.06.95/Makefile.in 2010-07-03 10:50:09.714725197 +0000
|
||||
@@ -149,7 +149,7 @@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-SUBDIRS = lib bc dc doc
|
||||
+SUBDIRS = lib bc dc
|
||||
MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
|
||||
stamp-h $(distdir).tar.gz h/number.h depcomp missing
|
||||
|
||||
--- bc-1.06.95/Makefile.am 2010-07-03 10:48:32.522725037 +0000
|
||||
+++ bc-1.06.95/Makefile.am 2010-07-03 10:48:38.114725024 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
|
||||
-SUBDIRS = lib bc dc doc
|
||||
+SUBDIRS = lib bc dc
|
||||
|
||||
MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
|
||||
stamp-h $(distdir).tar.gz h/number.h depcomp missing
|
Loading…
Reference in New Issue
Block a user