mirror of
http://git.openwrt.org/packages.git
synced 2025-01-09 04:19:54 +08:00
tor-alpha: remove obsolete package
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@45622 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6c0569db46
commit
c695963f5e
@ -1,122 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2008-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tor-alpha
|
||||
PKG_VERSION:=0.2.5.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=tor-$(PKG_VERSION)-alpha.tar.gz
|
||||
PKG_SOURCE_URL:=https://www.torproject.org/dist \
|
||||
https://archive.torproject.org/tor-package-archive \
|
||||
http://tor.mirror.tn/dist
|
||||
PKG_MD5SUM:=c913735a3527fec3e9bacf3a1e1a70bf
|
||||
|
||||
PKG_BUILD_DEPENDS:=libminiupnpc libnatpmp
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)-alpha
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/tor-alpha/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
URL:=https://www.torproject.org/
|
||||
endef
|
||||
|
||||
define Package/tor-alpha/Default/description
|
||||
Tor is a toolset for a wide range of organizations and people that want to
|
||||
improve their safety and security on the Internet. Using Tor can help you
|
||||
anonymize web browsing and publishing, instant messaging, IRC, SSH, and
|
||||
more. Tor also provides a platform on which software developers can build
|
||||
new applications with built-in anonymity, safety, and privacy features.
|
||||
endef
|
||||
|
||||
define Package/tor-alpha
|
||||
$(call Package/tor-alpha/Default)
|
||||
TITLE:=An anonymous Internet communication system
|
||||
DEPENDS:=+libevent2 +libopenssl +libpthread +librt +SSP_SUPPORT:libssp
|
||||
endef
|
||||
|
||||
define Package/tor-alpha/description
|
||||
$(call Package/tor-alpha/Default/description)
|
||||
This package contains the tor daemon.
|
||||
endef
|
||||
|
||||
define Package/tor-alpha-fw-helper
|
||||
$(call Package/tor-alpha/Default)
|
||||
TITLE:=Firewall helper for tor
|
||||
DEPENDS:=+tor-alpha +libminiupnpc +libnatpmp
|
||||
endef
|
||||
|
||||
define Package/tor-alpha-fw-helper/description
|
||||
$(call Package/tor-alpha/Default/description)
|
||||
This package contains a helper for automatically configuring port forwarding.
|
||||
endef
|
||||
|
||||
define Package/tor-alpha-geoip
|
||||
$(call Package/tor-alpha/Default)
|
||||
TITLE:=GeoIP db for tor
|
||||
DEPENDS:=+tor-alpha
|
||||
endef
|
||||
|
||||
define Package/tor-alpha-geoip/description
|
||||
$(call Package/tor-alpha/Default/description)
|
||||
This package contains a GeoIP database mapping IP addresses to countries.
|
||||
endef
|
||||
|
||||
define Package/tor-alpha/conffiles
|
||||
/etc/tor/torrc
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-libevent-dir="$(STAGING_DIR)/usr" \
|
||||
--with-ssl-dir="$(STAGING_DIR)/usr" \
|
||||
--enable-upnp \
|
||||
--with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
|
||||
--enable-nat-pmp \
|
||||
--with-libnatpmp-dir="$(STAGING_DIR)/usr" \
|
||||
--disable-asciidoc \
|
||||
--disable-threads
|
||||
|
||||
ifneq ($(CONFIG_SSP_SUPPORT),y)
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-gcc-hardening
|
||||
MAKE_FLAGS += \
|
||||
CFLAGS="$(TARGET_CFLAGS)"
|
||||
else
|
||||
MAKE_FLAGS += \
|
||||
CFLAGS="$(TARGET_CFLAGS) -fPIC"
|
||||
|
||||
endif
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CROSS_COMPILE="yes"
|
||||
|
||||
define Package/tor-alpha/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
|
||||
$(INSTALL_DIR) $(1)/etc/tor
|
||||
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
|
||||
endef
|
||||
|
||||
define Package/tor-alpha-fw-helper/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor-fw-helper $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/tor-alpha-geoip/install
|
||||
$(INSTALL_DIR) $(1)/usr/share/tor
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,tor-alpha))
|
||||
$(eval $(call BuildPackage,tor-alpha-fw-helper))
|
||||
$(eval $(call BuildPackage,tor-alpha-geoip))
|
@ -1,30 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
|
||||
START=50
|
||||
STOP=50
|
||||
|
||||
SERVICE_USE_PID=1
|
||||
|
||||
start() {
|
||||
user_exists tor 52 || user_add tor 52 52 /var/lib/tor
|
||||
group_exists tor 52 || group_add tor 52
|
||||
[ -f /var/run/tor.pid ] || {
|
||||
touch /var/run/tor.pid
|
||||
chown tor:tor /var/run/tor.pid
|
||||
}
|
||||
[ -d /var/lib/tor ] || {
|
||||
mkdir -m 0755 -p /var/lib/tor
|
||||
chmod 0700 /var/lib/tor
|
||||
chown tor:tor /var/lib/tor
|
||||
}
|
||||
[ -d /var/log/tor ] || {
|
||||
mkdir -m 0755 -p /var/log/tor
|
||||
chown tor:tor /var/log/tor
|
||||
}
|
||||
service_start /usr/sbin/tor --PidFile /var/run/tor.pid
|
||||
}
|
||||
|
||||
stop() {
|
||||
service_stop /usr/sbin/tor
|
||||
}
|
@ -1,21 +0,0 @@
|
||||
--- a/src/config/torrc.sample.in
|
||||
+++ b/src/config/torrc.sample.in
|
||||
@@ -45,11 +45,11 @@
|
||||
## Uncomment this to start the process in the background... or use
|
||||
## --runasdaemon 1 on the command line. This is ignored on Windows;
|
||||
## see the FAQ entry if you want Tor to run as an NT service.
|
||||
-#RunAsDaemon 1
|
||||
+RunAsDaemon 1
|
||||
|
||||
## The directory for keeping all the keys/etc. By default, we store
|
||||
## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
|
||||
-#DataDirectory @LOCALSTATEDIR@/lib/tor
|
||||
+DataDirectory @LOCALSTATEDIR@/lib/tor
|
||||
|
||||
## The port on which Tor will listen for local connections from Tor
|
||||
## controller applications, as documented in control-spec.txt.
|
||||
@@ -190,3 +190,4 @@
|
||||
## address manually to your friends, uncomment this line:
|
||||
#PublishServerDescriptor 0
|
||||
|
||||
+User tor
|
Loading…
Reference in New Issue
Block a user