[packages] sox: update to 14.4.1

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37594 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2013-07-28 23:28:23 +00:00
parent 83ee75c165
commit c94f13c392
4 changed files with 143 additions and 19 deletions

View File

@ -9,18 +9,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sox
PKG_VERSION:=14.4.0
PKG_VERSION:=14.4.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/sox
PKG_MD5SUM:=813807c6d6fcd4b0af5c995e61f46687
PKG_MD5SUM:=ff9ca6aca972549de0e80e8e30ed379c
PKG_LICENSE:=LGPLv2.1 GPLv2
PKG_LICENSE_FILES:=COPYING LICENSE.LGPL LICENSE.GPL
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -28,8 +26,6 @@ include $(INCLUDE_DIR)/package.mk
TARGET_LDFLAGS+= \
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
# NOTE: libflac is out of date for 8.09's freeze and can't be compiled in
define Package/sox
SECTION:=sound
CATEGORY:=Sound

View File

@ -9,10 +9,10 @@
play rec: sox$(EXEEXT)
if test "$(PLAYRECLINKS)" = "yes"; then \
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -2849,7 +2849,7 @@ uninstall-am: uninstall-binPROGRAMS unin
uninstall-pkglibLTLIBRARIES
--- sox-14.4.1/src/Makefile.in
+++ sox-14.4.1/src/Makefile.in
@@ -2904,7 +2904,7 @@
uninstall-libLTLIBRARIES uninstall-pkglibLTLIBRARIES
-all: sox$(EXEEXT) play rec soxi sox_sample_test$(EXEEXT) example0$(EXEEXT) example1$(EXEEXT) example2$(EXEEXT) example3$(EXEEXT) example4$(EXEEXT) example5$(EXEEXT)

View File

@ -1,20 +1,19 @@
--- a/src/formats.c
+++ b/src/formats.c
@@ -408,7 +408,7 @@ static void UNUSED rewind_pipe(FILE * fp
--- sox-14.4.1.orig/src/formats.c
+++ sox-14.4.1/src/formats.c
@@ -409,7 +409,7 @@ static void UNUSED rewind_pipe(FILE * fp
#if defined _FSTDIO || defined _NEWLIB_VERSION || defined __APPLE__
fp->_p -= AUTO_DETECT_SIZE;
fp->_r += AUTO_DETECT_SIZE;
fp->_p -= PIPE_AUTO_DETECT_SIZE;
fp->_r += PIPE_AUTO_DETECT_SIZE;
-#elif defined __GLIBC__
+#elif defined __GLIBC__ && ! defined __UCLIBC__
fp->_IO_read_ptr = fp->_IO_read_base;
#elif defined _MSC_VER || defined __MINGW_H || defined _ISO_STDIO_ISO_H
#elif defined _MSC_VER || defined _WIN32 || defined _WIN64 || defined _ISO_STDIO_ISO_H
fp->_ptr = fp->_base;
@@ -416,7 +416,7 @@ static void UNUSED rewind_pipe(FILE * fp
@@ -417,7 +417,6 @@ static void UNUSED rewind_pipe(FILE * fp
/* To fix this #error, either simply remove the #error line and live without
* file-type detection with pipes, or add support for your compiler in the
* lines above. Test with cat monkey.au | ./sox --info - */
* lines above. Test with cat monkey.wav | ./sox --info - */
- #error FIX NEEDED HERE
+/* #error FIX NEEDED HERE */
#define NO_REWIND_PIPE
(void)fp;
#endif

View File

@ -0,0 +1,129 @@
--- a/configure
+++ b/configure
@@ -15825,9 +15825,9 @@
cat >>confdefs.h <<_ACEOF
#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
_ACEOF
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for av_open_input_file in -lavformat" >&5
-$as_echo_n "checking for av_open_input_file in -lavformat... " >&6; }
-if ${ac_cv_lib_avformat_av_open_input_file+:} false; then :
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for avformat_open_input in -lavformat" >&5
+$as_echo_n "checking for avformat_open_input in -lavformat... " >&6; }
+if ${ac_cv_lib_avformat_avformat_open_input+:} false; then :
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -15841,27 +15841,27 @@
#ifdef __cplusplus
extern "C"
#endif
-char av_open_input_file ();
+char avformat_open_input ();
int
main ()
{
-return av_open_input_file ();
+return avformat_open_input ();
;
return 0;
}
_ACEOF
if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_lib_avformat_av_open_input_file=yes
+ ac_cv_lib_avformat_avformat_open_input=yes
else
- ac_cv_lib_avformat_av_open_input_file=no
+ ac_cv_lib_avformat_avformat_open_input=no
fi
rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_avformat_av_open_input_file" >&5
-$as_echo "$ac_cv_lib_avformat_av_open_input_file" >&6; }
-if test "x$ac_cv_lib_avformat_av_open_input_file" = xyes; then :
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_avformat_avformat_open_input" >&5
+$as_echo "$ac_cv_lib_avformat_avformat_open_input" >&6; }
+if test "x$ac_cv_lib_avformat_avformat_open_input" = xyes; then :
for ac_header in libavcodec/avcodec.h ffmpeg/avcodec.h
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
diff -Naur sox-14.4.0-orig/src/ffmpeg.c sox-14.4.0/src/ffmpeg.c
--- sox-14.4.0-orig/src/ffmpeg.c 2012-06-12 00:35:53.459027469 -0400
+++ sox-14.4.0/src/ffmpeg.c 2012-06-12 00:36:26.539028545 -0400
@@ -93,7 +93,7 @@
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
enc->error_resilience = 1;
#else
- enc->error_recognition = 1;
+ enc->err_recognition = 1;
#endif
if (!codec || avcodec_open(enc, codec) < 0)
@@ -157,7 +157,7 @@
static int startread(sox_format_t * ft)
{
priv_t * ffmpeg = (priv_t *)ft->priv;
- AVFormatParameters params;
+ AVDictionary *params;
int ret;
int i;
@@ -172,7 +172,7 @@
/* Open file and get format */
memset(&params, 0, sizeof(params));
- if ((ret = av_open_input_file(&ffmpeg->ctxt, ft->filename, NULL, 0, &params)) < 0) {
+ if ((ret = avformat_open_input(&ffmpeg->ctxt, ft->filename, NULL, &params)) < 0) {
lsx_fail("ffmpeg cannot open file for reading: %s (code %d)", ft->filename, ret);
return SOX_EOF;
}
@@ -231,7 +231,7 @@
/* If input buffer empty, read more data */
if (ffmpeg->audio_buf_index * 2 >= ffmpeg->audio_buf_size) {
if ((ret = av_read_frame(ffmpeg->ctxt, pkt)) < 0 &&
- (ret == AVERROR_EOF || url_ferror(ffmpeg->ctxt->pb)))
+ (ret == AVERROR_EOF || ffmpeg->ctxt->pb->error))
break;
ffmpeg->audio_buf_size = audio_decode_frame(ffmpeg, ffmpeg->audio_buf_aligned, AVCODEC_MAX_AUDIO_FRAME_SIZE);
ffmpeg->audio_buf_index = 0;
@@ -373,13 +373,6 @@
return SOX_EOF;
}
- /* set the output parameters (must be done even if no
- parameters). */
- if (av_set_parameters(ffmpeg->ctxt, NULL) < 0) {
- lsx_fail("ffmpeg invalid output format parameters");
- return SOX_EOF;
- }
-
/* Next line for debugging */
/* dump_format(ffmpeg->ctxt, 0, ft->filename, 1); */
@@ -391,14 +384,14 @@
/* open the output file, if needed */
if (!(ffmpeg->fmt->flags & AVFMT_NOFILE)) {
- if (url_fopen(&ffmpeg->ctxt->pb, ft->filename, URL_WRONLY) < 0) {
+ if (avio_open(&ffmpeg->ctxt->pb, ft->filename, AVIO_FLAG_WRITE) < 0) {
lsx_fail("ffmpeg could not open `%s'", ft->filename);
return SOX_EOF;
}
}
/* write the stream header, if any */
- av_write_header(ffmpeg->ctxt);
+ avformat_write_header(ffmpeg->ctxt, NULL);
return SOX_SUCCESS;
}
@@ -478,7 +471,7 @@
#if (LIBAVFORMAT_VERSION_INT < 0x340000)
url_fclose(&ffmpeg->ctxt->pb);
#else
- url_fclose(ffmpeg->ctxt->pb);
+ avio_close(ffmpeg->ctxt->pb);
#endif
}