mirror of
http://git.openwrt.org/packages.git
synced 2025-01-07 03:17:29 +08:00
python-crypto: moved to github
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@47529 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
89e16442dc
commit
cb71b73dea
@ -1,46 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pycrypto
|
||||
PKG_VERSION:=2.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/
|
||||
PKG_MD5SUM:=88dad0a270d1fe83a39e0467a66a22bb
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
$(call include_mk, python-package.mk)
|
||||
|
||||
define Package/python-crypto
|
||||
SECTION:=lang-python
|
||||
CATEGORY:=Languages
|
||||
SUBMENU:=Python
|
||||
TITLE:=python-crypto
|
||||
URL:=http://www.pycrypto.org/
|
||||
DEPENDS:=+python +libgmp
|
||||
endef
|
||||
|
||||
define Package/python-crypto/description
|
||||
A collection of both secure hash functions (such as MD5 and SHA),
|
||||
and various encryption algorithms (AES, DES, IDEA, RSA, ElGamal, etc.).
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
|
||||
endef
|
||||
|
||||
define Package/python-crypto/install
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
|
||||
$(1)$(PYTHON_PKG_DIR)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,python-crypto))
|
@ -1,11 +0,0 @@
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -370,7 +370,7 @@ kw = {'name':"pycrypto",
|
||||
'ext_modules': plat_ext + [
|
||||
# _fastmath (uses GNU mp library)
|
||||
Extension("Crypto.PublicKey._fastmath",
|
||||
- include_dirs=['src/','/usr/include/'],
|
||||
+ include_dirs=['src/'],
|
||||
libraries=['gmp'],
|
||||
sources=["src/_fastmath.c"]),
|
||||
|
Loading…
Reference in New Issue
Block a user