mdk3: pass our CFLAGS

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39812 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2014-03-08 00:57:07 +00:00
parent 0918445fde
commit cd3b652fff
3 changed files with 9 additions and 7 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2009-2010 OpenWrt.org
# Copyright (C) 2009-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mdk3
PKG_VERSION:=v6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MD5SUM:=67705a814ded2a2e6f70522ca0dc6da9
PKG_BUILD_DIR:=$(BUILD_DIR)/mdk3-$(PKG_VERSION)
@ -33,6 +33,9 @@ define Package/mdk3/description
Tool to exploit wireless vulnerabilities
endef
MAKE_FLAGS += \
$(TARGET_CONFIGURE_OPTS)
define Package/mdk3/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_BUILD_DIR)/mdk3 $(1)/usr/sbin/

View File

@ -1,6 +1,5 @@
diff -urN mdk3-v6/osdep/radiotap/radiotap-parser.c mdk3-v6.new/osdep/radiotap/radiotap-parser.c
--- mdk3-v6/osdep/radiotap/radiotap-parser.c 2009-08-16 18:16:14.000000000 +0200
+++ mdk3-v6.new/osdep/radiotap/radiotap-parser.c 2009-11-01 10:30:08.000000000 +0100
--- a/osdep/radiotap/radiotap-parser.c
+++ b/osdep/radiotap/radiotap-parser.c
@@ -18,6 +18,7 @@
#include <stdio.h>

View File

@ -2,8 +2,8 @@
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- mdk3-v6.orig/Makefile
+++ mdk3-v6/Makefile
--- a/Makefile
+++ b/Makefile
@@ -18,8 +18,8 @@ osd:
$(LIBOSD):
$(MAKE) -C $(OSD)