poco: moved to github

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@49036 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2016-03-19 10:42:21 +00:00
parent 1b9848d7b2
commit fde282654e
2 changed files with 0 additions and 89 deletions

View File

@ -1,63 +0,0 @@
#
# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=poco
PKG_VERSION:=1.3.6p2
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/poco/sources/poco-1.3.6
PKG_MD5SUM:=32d154ca5f34d20217c0baaffa432c1c
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/poco
NAME:=poco
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Poco C++ libraries
URL:=http://www.pocoproject.org/
DEPENDS:=+libstdcpp +libpthread +librt
endef
define Package/poco/description
Modern, powerful open source C++ class libraries and frameworks for building
network- and internet-based applications that run on desktop, server and
embedded systems.
endef
CONFIGURE_ARGS += \
--config=Linux \
--no-tests \
--no-samples \
--no-fpenvironment \
--no-sharedmemory \
--no-wstring
MAKE_FLAGS += \
CXXFLAGS32="$(TARGET_CXXFLAGS)" \
CFLAGS32="$(TARGET_CFLAGS)" \
LINKFLAGS32="$(TARGET_LDFLAGS)"
define Package/poco/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,Net,Util}.so* $(1)/usr/lib/
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) -r $(PKG_INSTALL_DIR)/usr/include/Poco $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,Net,Util}.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,poco))

View File

@ -1,26 +0,0 @@
--- a/configure
+++ b/configure
@@ -50,6 +50,11 @@
Useful if your C++ compiler has incomplete floating-point support
(such as uClibc-based systems).
+ --no-sharedmemory
+ Compile with -DPOCO_NO_SHAREDMEMORY
+ Useful if your C++ compiler has incomplete shared memory support
+ (such as uClibc-based systems).
+
--omit=<component>{,<component>}
Do not build the specified component(s).
Example: --omit=Data/MySQL,Data/ODBC,Zip
@@ -140,6 +145,10 @@
flags="$flags -DPOCO_NO_FPENVIRONMENT"
fi
+ if [ "$1" = "--no-sharedmemory" ] ; then
+ flags="$flags -DPOCO_NO_SHAREDMEMORY"
+ fi
+
if [ "$1" = "--poquito" ] ; then
flags="$flags -DPOCO_NO_FILECHANNEL -DPOCO_NO_SPLITTERCHANNEL -DPOCO_NO_SYSLOGCHANNEL -DPOCO_UTIL_NO_INIFILECONFIGURATION -DPOCO_UTIL_NO_XMLCONFIGURATION"
fi