mirror of
https://github.com/roacn/openwrt-packages.git
synced 2025-01-08 11:57:31 +08:00
🔥 Sync 2022-11-19 10:03
This commit is contained in:
parent
4557c2ec4d
commit
108ad2bb4c
@ -5,12 +5,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=brook
|
||||
PKG_VERSION:=20221010
|
||||
PKG_VERSION:=20221212
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/txthinking/brook/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=987b2ddac349e5ac2b91b40b06f7686dcf316c37bfe82c566fdc7503f0b4d97d
|
||||
PKG_HASH:=bc0bf33d65a31fd85a2eb50ea9dcfffa0fb66f0213e5d6eb94a69fcdd8a6007d
|
||||
|
||||
PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
|
@ -0,0 +1,35 @@
|
||||
From 82282323abc1883949c63d35b59f26aa7adc42e3 Mon Sep 17 00:00:00 2001
|
||||
From: Tianling Shen <i@cnsztl.eu.org>
|
||||
Date: Thu, 10 Nov 2022 22:59:58 +0800
|
||||
Subject: [PATCH] chore(deps): update iploc to fix build with mips
|
||||
|
||||
Signed-off-by: Tianling Shen <i@cnsztl.eu.org>
|
||||
---
|
||||
go.mod | 2 +-
|
||||
go.sum | 4 ++--
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/go.mod
|
||||
+++ b/go.mod
|
||||
@@ -8,7 +8,7 @@ require (
|
||||
github.com/mdp/qrterminal v1.0.1
|
||||
github.com/miekg/dns v1.1.43
|
||||
github.com/patrickmn/go-cache v2.1.0+incompatible
|
||||
- github.com/phuslu/iploc v1.0.20220930
|
||||
+ github.com/phuslu/iploc v1.0.20221110
|
||||
github.com/tdewolff/minify v2.3.6+incompatible
|
||||
github.com/txthinking/crypto v0.0.0-20210716135230-de9624a415a4
|
||||
github.com/txthinking/runnergroup v0.0.0-20210608031112-152c7c4432bf
|
||||
--- a/go.sum
|
||||
+++ b/go.sum
|
||||
@@ -10,8 +10,8 @@ github.com/miekg/dns v1.1.43 h1:JKfpVSCB
|
||||
github.com/miekg/dns v1.1.43/go.mod h1:+evo5L0630/F6ca/Z9+GAqzhjGyn8/c+TBaOyfEl0V4=
|
||||
github.com/patrickmn/go-cache v2.1.0+incompatible h1:HRMgzkcYKYpi3C8ajMPV8OFXaaRUnok+kx1WdO15EQc=
|
||||
github.com/patrickmn/go-cache v2.1.0+incompatible/go.mod h1:3Qf8kWWT7OJRJbdiICTKqZju1ZixQ/KpMGzzAfe6+WQ=
|
||||
-github.com/phuslu/iploc v1.0.20220930 h1:Cx8cGRjQ87iYUUOEduaJt2CfTIv6RL58mnn6UtH/bao=
|
||||
-github.com/phuslu/iploc v1.0.20220930/go.mod h1:gsgExGWldwv1AEzZm+Ki9/vGfyjkL33pbSr9HGpt2Xg=
|
||||
+github.com/phuslu/iploc v1.0.20221110 h1:XB8F6N3NyD0iKB4hQ/y1LuQyqSJD8g+xEPWTUNJHR80=
|
||||
+github.com/phuslu/iploc v1.0.20221110/go.mod h1:gsgExGWldwv1AEzZm+Ki9/vGfyjkL33pbSr9HGpt2Xg=
|
||||
github.com/russross/blackfriday/v2 v2.1.0 h1:JIOH55/0cWyOuilr9/qlrm0BSXldqnqwMsf35Ld67mk=
|
||||
github.com/russross/blackfriday/v2 v2.1.0/go.mod h1:+Rmxgy9KzJVeS9/2gXHxylqXiyQDYRxCVz55jmeOWTM=
|
||||
github.com/tdewolff/minify v2.3.6+incompatible h1:2hw5/9ZvxhWLvBUnHE06gElGYz+Jv9R4Eys0XUzItYo=
|
@ -9,7 +9,7 @@ PKG_VERSION:=1.3.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/HyNetwork/hysteria/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/apernet/hysteria/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=76137ec58245df72f9f8258bad1627bbd157f9ca5475b49e0ad897f22d7e7baf
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
@ -31,7 +31,7 @@ define Package/hysteria
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=A feature-packed network utility optimized for networks of poor quality
|
||||
URL:=https://github.com/tobyxdd/hysteria
|
||||
URL:=https://github.com/apernet/hysteria
|
||||
DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle
|
||||
endef
|
||||
|
||||
|
@ -5,12 +5,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=naiveproxy
|
||||
PKG_VERSION:=107.0.5304.87-1
|
||||
PKG_VERSION:=107.0.5304.87-3
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/klzgrad/naiveproxy/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=f97f0ad880e5a784bd3fa5dd5d114434ab7e393736d90a902c0d2d3ec95e9ff0
|
||||
PKG_HASH:=a97787c8fff1d3569398dd9cbd263ca8688c919352db08478d2cc2668559cf23
|
||||
|
||||
PKG_LICENSE:=BSD 3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -44,10 +44,6 @@ symbol_level=1
|
||||
is_clang=true
|
||||
use_sysroot=false
|
||||
|
||||
use_allocator=\"none\"
|
||||
use_allocator_shim=false
|
||||
use_partition_alloc=false
|
||||
|
||||
fatal_linker_warnings=false
|
||||
treat_warnings_as_errors=false
|
||||
|
||||
@ -93,6 +89,12 @@ case "${target_arch}" in
|
||||
;;
|
||||
"mipsel"|"mips64el")
|
||||
naive_flags+=" use_thin_lto=false chrome_pgo_phase=0 mips_arch_variant=\"r2\""
|
||||
[ "${target_arch}" == "mipsel" ] && naive_flags+=" mips_float_abi=\"soft\""
|
||||
if [ "${target_arch}" == "mipsel" ]; then
|
||||
if [ "${cpu_subtype}" == "24kf" ]; then
|
||||
naive_flags+=" mips_float_abi=\"hard\""
|
||||
else
|
||||
naive_flags+=" mips_float_abi=\"soft\""
|
||||
fi
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
|
@ -5,12 +5,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xray-plugin
|
||||
PKG_VERSION:=1.6.3
|
||||
PKG_VERSION:=1.6.4
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/teddysun/xray-plugin/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=0e4eb348ad66d04998e615ebcf987f93f916dfd2ceeee70451d40183664de0dc
|
||||
PKG_HASH:=4088dd7a22dfdcc54b73cb4b462dc9ffeb63821d0edf954da9bf33e88252e85b
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user