mirror of
https://github.com/roacn/openwrt-packages.git
synced 2025-01-09 04:18:08 +08:00
🦄 Sync 2023-10-05 14:32
This commit is contained in:
parent
81cac932ed
commit
16b3e93af7
107
iperf3/Makefile
107
iperf3/Makefile
@ -1,107 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2007-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iperf
|
||||
PKG_VERSION:=3.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://downloads.es.net/pub/iperf
|
||||
PKG_HASH:=72034ecfb6a7d6d67e384e19fb6efff3236ca4f7ed4c518d7db649c447e1ffd6
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
DISABLE_NLS:=
|
||||
|
||||
define Package/iperf3/default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=Internet Protocol bandwidth measuring tool
|
||||
URL:=https://github.com/esnet/iperf
|
||||
endef
|
||||
|
||||
define Package/iperf3
|
||||
$(call Package/iperf3/default)
|
||||
VARIANT:=nossl
|
||||
DEPENDS:=+libiperf3
|
||||
endef
|
||||
|
||||
define Package/iperf3-ssl
|
||||
$(call Package/iperf3/default)
|
||||
TITLE+= with iperf_auth support
|
||||
VARIANT:=ssl
|
||||
DEPENDS:=+libopenssl
|
||||
endef
|
||||
|
||||
define Package/libiperf3
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Internet Protocol bandwidth measuring library
|
||||
URL:=https://github.com/esnet/iperf
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -D_GNU_SOURCE
|
||||
|
||||
ifeq ($(BUILD_VARIANT), ssl)
|
||||
CONFIGURE_ARGS += --with-openssl="$(STAGING_DIR)/usr" --disable-shared
|
||||
else
|
||||
CONFIGURE_ARGS += --without-openssl
|
||||
endif
|
||||
|
||||
MAKE_FLAGS += noinst_PROGRAMS=
|
||||
|
||||
define Package/iperf3/description
|
||||
Iperf is a modern alternative for measuring TCP and UDP bandwidth
|
||||
performance, allowing the tuning of various parameters and
|
||||
characteristics.
|
||||
endef
|
||||
|
||||
define Package/libiperf3/description
|
||||
Libiperf is a library providing an API for iperf3 functionality.
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiperf.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
endef
|
||||
|
||||
# autoreconf fails if the README file isn't present
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
touch $(PKG_BUILD_DIR)/README
|
||||
endef
|
||||
|
||||
define Package/iperf3/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/iperf3 $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iperf3-ssl/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/iperf3 $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/libiperf3/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiperf.so.* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,iperf3))
|
||||
$(eval $(call BuildPackage,iperf3-ssl))
|
||||
$(eval $(call BuildPackage,libiperf3))
|
105
netdata/Makefile
105
netdata/Makefile
@ -1,105 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2008-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=netdata
|
||||
PKG_VERSION:=1.33.1
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>, Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:my-netdata:netdata
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/netdata/netdata/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=20ba8695d87187787b27128ac3aab9b09aa29ca6b508c48542e0f7d50ec9322b
|
||||
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/netdata
|
||||
SECTION:=admin
|
||||
CATEGORY:=Administration
|
||||
DEPENDS:=+zlib +libuuid +libuv +libmnl +libjson-c
|
||||
TITLE:=Real-time performance monitoring tool
|
||||
URL:=https://www.netdata.cloud/
|
||||
endef
|
||||
|
||||
define Package/netdata/description
|
||||
netdata is a highly optimized Linux daemon providing real-time performance
|
||||
monitoring for Linux systems, applications and SNMP devices over the web.
|
||||
|
||||
If you want to use Python plugins install python3, python3-yaml and
|
||||
python3-urllib3
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS := $(filter-out -O%,$(TARGET_CFLAGS))
|
||||
TARGET_CFLAGS += -ffunction-sections -fdata-sections -O3
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-zlib \
|
||||
--with-math \
|
||||
--disable-x86-sse \
|
||||
--enable-lto \
|
||||
--disable-ebpf \
|
||||
--without-libcap \
|
||||
--disable-https \
|
||||
--disable-dbengine \
|
||||
--disable-compression \
|
||||
--disable-plugin-nfacct \
|
||||
--disable-plugin-freeipmi \
|
||||
--disable-plugin-cups \
|
||||
--disable-plugin-xenstat \
|
||||
--disable-backend-prometheus-remote-write \
|
||||
--disable-unit-tests \
|
||||
--disable-ml \
|
||||
--disable-cloud
|
||||
|
||||
define Build/Configure
|
||||
$(SED) 's/m4_esyscmd(\[git describe .*\])/$(PKG_VERSION)/' $(PKG_BUILD_DIR)/configure.ac
|
||||
$(Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Package/netdata/conffiles
|
||||
/etc/netdata/
|
||||
endef
|
||||
|
||||
define Package/netdata/install
|
||||
$(INSTALL_DIR) $(1)/etc/netdata/custom-plugins.d
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/netdata $(1)/etc
|
||||
$(CP) ./files/netdata.conf $(1)/etc/netdata
|
||||
touch $(1)/etc/netdata/.opt-out-from-anonymous-statistics
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/netdata $(1)/usr/lib
|
||||
$(CP) $(1)/usr/lib/netdata/conf.d/fping.conf $(1)/etc
|
||||
$(CP) $(1)/usr/lib/netdata/conf.d/health_alarm_notify.conf $(1)/etc
|
||||
$(CP) $(1)/usr/lib/netdata/plugins.d/tc-qos-helper.sh $(1)/etc
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/netdata $(1)/usr/sbin
|
||||
$(INSTALL_DIR) $(1)/usr/share/netdata
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/netdata $(1)/usr/share
|
||||
rm $(1)/usr/share/netdata/web/demo*html
|
||||
rm $(1)/usr/share/netdata/web/fonts/*.svg
|
||||
rm $(1)/usr/share/netdata/web/fonts/*.ttf
|
||||
rm $(1)/usr/share/netdata/web/fonts/*.woff
|
||||
rm $(1)/usr/share/netdata/web/images/*.png
|
||||
rm $(1)/usr/share/netdata/web/images/*.gif
|
||||
rm $(1)/usr/share/netdata/web/images/*.ico
|
||||
rm -rf $(1)/usr/share/netdata/web/old
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/netdata.init $(1)/etc/init.d/netdata
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,netdata))
|
@ -1,32 +0,0 @@
|
||||
# Full configuration can be retrieved from the running
|
||||
# server at http://localhost:19999/netdata.conf
|
||||
#
|
||||
# Example:
|
||||
# curl -o /etc/netdata/netdata.conf http://localhost:19999/netdata.conf
|
||||
#
|
||||
|
||||
[global]
|
||||
update every = 2
|
||||
memory deduplication (ksm) = no
|
||||
debug log = syslog
|
||||
error log = syslog
|
||||
access log = none
|
||||
run as user = root
|
||||
|
||||
[web]
|
||||
allow connections from = localhost 10.* 192.168.* 172.16.* 172.17.* 172.18.* 172.19.* 172.20.* 172.21.* 172.22.* 172.23.* 172.24.* 172.25.* 172.26.* 172.27.* 172.28.* 172.29.* 172.30.* 172.31.*
|
||||
allow dashboard from = localhost 10.* 192.168.* 172.16.* 172.17.* 172.18.* 172.19.* 172.20.* 172.21.* 172.22.* 172.23.* 172.24.* 172.25.* 172.26.* 172.27.* 172.28.* 172.29.* 172.30.* 172.31.*
|
||||
|
||||
[plugins]
|
||||
cgroups = no
|
||||
apps = no
|
||||
charts.d = no
|
||||
fping = no
|
||||
node.d = no
|
||||
python.d = no
|
||||
|
||||
[health]
|
||||
enabled = no
|
||||
|
||||
[plugin:proc:ipc]
|
||||
shared memory totals = no
|
@ -1,21 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=99
|
||||
USE_PROCD=1
|
||||
|
||||
APPBINARY=/usr/sbin/netdata
|
||||
CONFIGFILE=/etc/netdata/netdata.conf
|
||||
|
||||
start_service() {
|
||||
mkdir -m 0755 -p /var/cache/netdata
|
||||
chown nobody /var/cache/netdata
|
||||
mkdir -m 0755 -p /var/lib/netdata
|
||||
chown nobody /var/lib/netdata
|
||||
mkdir -m 0755 -p /var/log/netdata
|
||||
chown nobody /var/log/netdata
|
||||
procd_open_instance
|
||||
procd_set_param command $APPBINARY -D -c $CONFIGFILE
|
||||
procd_set_param file $CONFIGFILE
|
||||
procd_set_param respawn
|
||||
procd_close_instance
|
||||
}
|
@ -1,22 +0,0 @@
|
||||
--- a/collectors/charts.d.plugin/charts.d.conf
|
||||
+++ b/collectors/charts.d.plugin/charts.d.conf
|
||||
@@ -30,7 +30,7 @@
|
||||
|
||||
# the default enable/disable for all charts.d collectors
|
||||
# the default is "yes"
|
||||
-# enable_all_charts="yes"
|
||||
+enable_all_charts="no"
|
||||
|
||||
# BY DEFAULT ENABLED MODULES
|
||||
# ap=yes
|
||||
--- a/collectors/python.d.plugin/python.d.conf
|
||||
+++ b/collectors/python.d.plugin/python.d.conf
|
||||
@@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
# Enable / disable the whole python.d.plugin (all its modules)
|
||||
-enabled: yes
|
||||
+enabled: no
|
||||
|
||||
# ----------------------------------------------------------------------
|
||||
# Enable / Disable python.d.plugin modules
|
@ -1,15 +0,0 @@
|
||||
--- a/web/gui/main.js
|
||||
+++ b/web/gui/main.js
|
||||
@@ -759,11 +759,7 @@ function renderMyNetdataMenu(machinesArr
|
||||
if (!isSignedIn()) {
|
||||
if (!NETDATA.registry.isRegistryEnabled()) {
|
||||
html += (
|
||||
- `<div class="info-item" style="white-space: nowrap">
|
||||
- <span>Please <a href="#" onclick="signInDidClick(event); return false">sign in to netdata.cloud</a> to view your nodes!</span>
|
||||
- <div></div>
|
||||
- </div>
|
||||
- <hr />`
|
||||
+ ``
|
||||
);
|
||||
}
|
||||
}
|
@ -1,112 +0,0 @@
|
||||
--- a/collectors/python.d.plugin/Makefile.am
|
||||
+++ b/collectors/python.d.plugin/Makefile.am
|
||||
@@ -147,109 +147,3 @@ dist_third_party_DATA = \
|
||||
python_modules/third_party/monotonic.py \
|
||||
python_modules/third_party/filelock.py \
|
||||
$(NULL)
|
||||
-
|
||||
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
|
||||
-dist_pythonyaml2_DATA = \
|
||||
- python_modules/pyyaml2/__init__.py \
|
||||
- python_modules/pyyaml2/composer.py \
|
||||
- python_modules/pyyaml2/constructor.py \
|
||||
- python_modules/pyyaml2/cyaml.py \
|
||||
- python_modules/pyyaml2/dumper.py \
|
||||
- python_modules/pyyaml2/emitter.py \
|
||||
- python_modules/pyyaml2/error.py \
|
||||
- python_modules/pyyaml2/events.py \
|
||||
- python_modules/pyyaml2/loader.py \
|
||||
- python_modules/pyyaml2/nodes.py \
|
||||
- python_modules/pyyaml2/parser.py \
|
||||
- python_modules/pyyaml2/reader.py \
|
||||
- python_modules/pyyaml2/representer.py \
|
||||
- python_modules/pyyaml2/resolver.py \
|
||||
- python_modules/pyyaml2/scanner.py \
|
||||
- python_modules/pyyaml2/serializer.py \
|
||||
- python_modules/pyyaml2/tokens.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-pythonyaml3dir=$(pythonmodulesdir)/pyyaml3
|
||||
-dist_pythonyaml3_DATA = \
|
||||
- python_modules/pyyaml3/__init__.py \
|
||||
- python_modules/pyyaml3/composer.py \
|
||||
- python_modules/pyyaml3/constructor.py \
|
||||
- python_modules/pyyaml3/cyaml.py \
|
||||
- python_modules/pyyaml3/dumper.py \
|
||||
- python_modules/pyyaml3/emitter.py \
|
||||
- python_modules/pyyaml3/error.py \
|
||||
- python_modules/pyyaml3/events.py \
|
||||
- python_modules/pyyaml3/loader.py \
|
||||
- python_modules/pyyaml3/nodes.py \
|
||||
- python_modules/pyyaml3/parser.py \
|
||||
- python_modules/pyyaml3/reader.py \
|
||||
- python_modules/pyyaml3/representer.py \
|
||||
- python_modules/pyyaml3/resolver.py \
|
||||
- python_modules/pyyaml3/scanner.py \
|
||||
- python_modules/pyyaml3/serializer.py \
|
||||
- python_modules/pyyaml3/tokens.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3dir=$(pythonmodulesdir)/urllib3
|
||||
-dist_python_urllib3_DATA = \
|
||||
- python_modules/urllib3/__init__.py \
|
||||
- python_modules/urllib3/_collections.py \
|
||||
- python_modules/urllib3/connection.py \
|
||||
- python_modules/urllib3/connectionpool.py \
|
||||
- python_modules/urllib3/exceptions.py \
|
||||
- python_modules/urllib3/fields.py \
|
||||
- python_modules/urllib3/filepost.py \
|
||||
- python_modules/urllib3/response.py \
|
||||
- python_modules/urllib3/poolmanager.py \
|
||||
- python_modules/urllib3/request.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3_utildir=$(python_urllib3dir)/util
|
||||
-dist_python_urllib3_util_DATA = \
|
||||
- python_modules/urllib3/util/__init__.py \
|
||||
- python_modules/urllib3/util/connection.py \
|
||||
- python_modules/urllib3/util/request.py \
|
||||
- python_modules/urllib3/util/response.py \
|
||||
- python_modules/urllib3/util/retry.py \
|
||||
- python_modules/urllib3/util/selectors.py \
|
||||
- python_modules/urllib3/util/ssl_.py \
|
||||
- python_modules/urllib3/util/timeout.py \
|
||||
- python_modules/urllib3/util/url.py \
|
||||
- python_modules/urllib3/util/wait.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3_packagesdir=$(python_urllib3dir)/packages
|
||||
-dist_python_urllib3_packages_DATA = \
|
||||
- python_modules/urllib3/packages/__init__.py \
|
||||
- python_modules/urllib3/packages/ordered_dict.py \
|
||||
- python_modules/urllib3/packages/six.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3_backportsdir=$(python_urllib3_packagesdir)/backports
|
||||
-dist_python_urllib3_backports_DATA = \
|
||||
- python_modules/urllib3/packages/backports/__init__.py \
|
||||
- python_modules/urllib3/packages/backports/makefile.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3_ssl_match_hostnamedir=$(python_urllib3_packagesdir)/ssl_match_hostname
|
||||
-dist_python_urllib3_ssl_match_hostname_DATA = \
|
||||
- python_modules/urllib3/packages/ssl_match_hostname/__init__.py \
|
||||
- python_modules/urllib3/packages/ssl_match_hostname/_implementation.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3_contribdir=$(python_urllib3dir)/contrib
|
||||
-dist_python_urllib3_contrib_DATA = \
|
||||
- python_modules/urllib3/contrib/__init__.py \
|
||||
- python_modules/urllib3/contrib/appengine.py \
|
||||
- python_modules/urllib3/contrib/ntlmpool.py \
|
||||
- python_modules/urllib3/contrib/pyopenssl.py \
|
||||
- python_modules/urllib3/contrib/securetransport.py \
|
||||
- python_modules/urllib3/contrib/socks.py \
|
||||
- $(NULL)
|
||||
-
|
||||
-python_urllib3_securetransportdir=$(python_urllib3_contribdir)/_securetransport
|
||||
-dist_python_urllib3_securetransport_DATA = \
|
||||
- python_modules/urllib3/contrib/_securetransport/__init__.py \
|
||||
- python_modules/urllib3/contrib/_securetransport/bindings.py \
|
||||
- python_modules/urllib3/contrib/_securetransport/low_level.py \
|
||||
- $(NULL)
|
@ -1,14 +0,0 @@
|
||||
--- a/collectors/python.d.plugin/python_modules/bases/loaders.py
|
||||
+++ b/collectors/python.d.plugin/python_modules/bases/loaders.py
|
||||
@@ -10,9 +10,9 @@ PY_VERSION = version_info[:2]
|
||||
|
||||
try:
|
||||
if PY_VERSION > (3, 1):
|
||||
- from pyyaml3 import SafeLoader as YamlSafeLoader
|
||||
+ from yaml import SafeLoader as YamlSafeLoader
|
||||
else:
|
||||
- from pyyaml2 import SafeLoader as YamlSafeLoader
|
||||
+ from yaml import SafeLoader as YamlSafeLoader
|
||||
except ImportError:
|
||||
from yaml import SafeLoader as YamlSafeLoader
|
||||
|
File diff suppressed because one or more lines are too long
@ -1,3 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
netdata -version 2>&1 | grep "$2"
|
Loading…
Reference in New Issue
Block a user